GIMP

Ads
 

GIMP

This page discusses - GIMP

This page discusses - GIMP

GIMP

     

This is the recommended version of Gimp. GIMP binary available on this page requires a Pentium II, Celeron, Athlon or better CPU.

Base packages

Warning: antispyware products based on CA/eTrust engine (such as Virgin Media PCGuard) wrongly identifiy the installer as being infected with RegistryCleanFix2008.

Click here to download: http://gimp-win.sourceforge.net/stable.html

     

Ads

Ads