Share on Google+Share on Google+

Eclipse Me Plugin

Advertisement
EclipseME is an Eclipse plugin to help develop J2ME MIDlets. EclipseME does the "grunt work" of connecting Wireless Toolkits to the Eclipse development environment, allowing you to focus on developing your application, rather than worrying about the speci

Eclipse Me Plugin

     
      

EclipseME is an Eclipse plugin to help develop J2ME MIDlets. EclipseME does the "grunt work" of connecting Wireless Toolkits to the Eclipse development environment, allowing you to focus on developing your application, rather than worrying about the special needs of J2ME development.

Version 1.7.5 of EclipseME has been released. This version provides a small set of bug fixes against version 1.7.3. In addition, the preprocessing engine has been replaced with the new Antenna preprocessor implementation from Omry Yadan. This preprocessor provides significant new processing functionality. For more information on using this new functionality, please visit http://antenna.sourceforge.net/wtkpreprocess.php.

In order to use the preprocessing support, it is absolutely necessary that the new installation instructions be followed in order to enable the preprocessing support.

Version 1.7.3 Released
Version 1.7.3 of EclipseME has been released. This version replaces the previously removed 1.7.0 version. The new release is the first to provide the new incremental deployed JAR builder functionality. With this release, all incremental building results in a valid JAR file that should be mostly deployable. In addition, support for MicroEmulator, ME4SE and Motorola has been added.

In order to use the preprocessing support, it is absolutely necessary that the new installation instructions be followed in order to enable the preprocessing support. EclipseME requires version 3.2 of the Eclipse platform. Eclipse 3.2.2 is suggested. Eclipse 3.3 should work, but is not heavily tested at this time.

Version 1.7.0 Removed 
Version 1.7.0 had a number of builder problems that have caused people quite a bit of trouble. Because of those problems, it has been determined that it would be better to remove that version until a fixed version can be made available. Version 1.7.0 has been removed from Sourceforge and the update site has been reverted to version 1.6.8. If you are currently using version 1.7.0 without problems, you are free to continue using the release until the next release is available. If you are having problems and would like to revert, please follow the instructions to remove the 1.7.0 release and follow the standard installation instructions to install version 1.6.8.

Version 1.6.8 Released 
Version 1.6.8 of EclipseME has been released. This version provides a small set of bug fixes against version 1.6.7. With these fixes, Linux users should be able to use UEI emulators once again. It is absolutely necessary that the new installation instructions be followed in order to enable the preprocessing support as currently provided. EclipseME requires version 3.2 of the Eclipse platform. Eclipse 3.2.2 is suggested, but 3.1 is no longer supported. Eclipse 3.3 should work, but is not heavily tested at this time.

Version 1.6.7 Released

Version 1.6.7 of EclipseME has been released. This version provides a small set of bug fixes against version 1.6.6. It is absolutely necessary that the new installation instructions be followed in order to enable the preprocessing support as currently provided. EclipseME requires version 3.2 of the Eclipse platform. Eclipse 3.2.2 is suggested, but 3.1 is no longer supported. Eclipse 3.3 should work, but is not heavily tested at this time.

 Know click for more information.

http://eclipseme.org/

     

Advertisements

Advertisement

Posted on: March 8, 2008 If you enjoyed this post then why not add us on Google+? Add us to your Circles

Share this Tutorial Follow us on Twitter, or add us on Facebook or Google Plus to keep you updated with the recent trends of Java and other open source platforms.

Discuss: Eclipse Me Plugin   View All Comments

Post your Comment


Your Name (*) :
Your Email :
Subject (*):
Your Comment (*):
  Reload Image
 
 
Comments:0